fsmzhs / WEN98的公式 / 【新提醒】凹口平衡線畫線公式(通達信含未...

0 0

   

【新提醒】凹口平衡線畫線公式(通達信含未來)

2012-04-09  fsmzhs
王子理論告訴我們:“每逢股價上交平衡線時都有中到大陽線出現”;“凹口平衡線是神奇的股價起跳板”。這就是“凹口淘金”的奧秘!可見,尋找并畫出“凹口平衡線”具有非常重要的意義!
  很久以前,剛學編公式(開始賣學分賺第一桶金)的時候,曾經編過“凹口平衡線選股公式”(原貼:http://www.178448.com/thread-88774-1-2.html)。但只是很不成熟的初選公式,而且沒有畫出線來。
  現在的這個凹口平衡線畫線公式,比前面的要好些,能找出凹口平衡的位置,并且自動畫線。根據王子的凹口平衡線理論,(量柱書P155)凹口平衡線的凹口取點,一般是“跌破左側陽線的那根大陰線的最低點”。但是我發現左側不一定要陽線,只要“跌破左側峰頂K線的那根大陰線”就可以了。所以公式也是按照這點來編寫的。
  特別聲明的是,為了畫圖的方便,還是采用了未來函數,不喜歡的就不要用了。公式疑似為畫線而畫線,并沒有完全體現王子的凹口平衡線思想原意,一些真正的凹口平衡線(“主力刻意打壓股價最兇狠的那根陰線”或“主力意圖最明顯的那個最低點”)并沒有畫出來,還得手工畫。編者水平所限,的確無法準確表達。無奈那些高手都不肯出手,只好充數了。畫線公式僅供參考!
  (增值部分:公式后面增加了“(大陰線實頂)平衡線”畫線,當跌率>4%時畫綠線,見圖2。)
  (再增值:凹口平衡線選股公式)
  請來支持、評分:http://www.178448.com/thread-169815-1-1.html
 
{凹口平衡線主圖,不會設參數、不喜未來的,勿用}
{設置參數:百分比(3,20,5); }
ZIG(3,百分比);{此行可省};
波峰距離: PEAKBARS(3,百分比,1),NODRAW;
波谷值:=TROUGH(2,百分比,1);
波谷距離:=TROUGHBARS(2,百分比,1);{HTTP://U.178448.COM/SPACE.PHP?UID=30578}
距離:=CURRBARSCOUNT,NODRAW;      {WEN98編寫}
C2:=REF(C,1);
比前跌率:=(C2-C)*100/C2;
本日跌率:=(O-C)*100/O;
距離FK1:=波峰距離-1;{波峰右邊K距離}
線位置:= REF(L,距離FK1),{NODRAW};
TJ1:=波峰距離>波谷距離+5 AND 波峰距離<120;
TJ2:=REF(本日跌率,距離FK1)>3 OR REF(比前跌率,距離FK1)>3;{跌率>3%}
TJ3:=距離<240;
TJ4:=REF(C,距離FK1)<REF(O,距離FK1) {陰K}
 AND REF(C,距離FK1)<REF(MIN(C,O),距離FK1+1);{跌破前K}
畫線條件:= 線位置=REF(線位置,1) AND TJ2 AND TJ4;{畫線條件}
STICKLINE(畫線條件,線位置,線位置,15,1),COLORMAGENTA;{畫線}
畫線: IF(畫線條件,線位置,DRAWNULL),COLORMAGENTA;{畫線}
打字條件:=FILTER(畫線條件 AND TJ1 AND TJ3,20);
DRAWTEXT(打字條件,線位置*1.01,'凹口平衡線'),COLORMAGENTA;{此行可省};
{=============大陰線實頂平衡線,加上去主圖花了一些========================}
MA5:=MA(C,5);
平衡線:=(比前跌率>4 OR 本日跌率>4) AND C<MA5;{4可自己調為3-10}
STICKLINE(平衡線,O,O,45,-1),COLORGREEN;{畫綠虛線};
 
 
以下是對應的選股公式:(下圖為參數設置示意圖)

{選股公式: 不會設參數、不喜未來的,勿用}
{設置參數:百分比(3,20,5); }
RC1:=REF(C,1);
比前跌率:=(RC1-C)*100/RC1;
本日跌率:=(O-C)*100/O;
波峰距離:= PEAKBARS(3,百分比,1);
波谷距離:=TROUGHBARS(2,百分比,1);{HTTP://U.178448.COM/SPACE.PHP?UID=30578}
距離:=CURRBARSCOUNT;             {WEN98編寫}
距離FK1:=波峰距離-1;{波峰右邊K距離}
線位置:= REF(L,距離FK1),{NODRAW};
TJ1:=波峰距離>波谷距離+5 AND 波峰距離<120;
TJ2:=REF(本日跌率,距離FK1)>3 OR REF(比前跌率,距離FK1)>3;{跌率>3%}
TJ3:=距離<240;
TJ4:=REF(C,距離FK1)<REF(O,距離FK1) {陰K}
 AND REF(C,距離FK1)<REF(MIN(C,O),距離FK1+1);{跌破前K}
畫線條件:= 線位置=REF(線位置,1) AND TJ2 AND TJ4;{畫線條件}
XG: 畫線條件 AND TJ1 AND TJ3 AND BETWEEN(C,線位置*0.98,線位置*1.01);
 
下面是凹口平衡線畫線效果圖:
 

    本站是提供個人知識管理的網絡存儲空間,所有內容均由用戶發布,不代表本站觀點。如發現有害或侵權內容,請點擊這里 或 撥打24小時舉報電話:4000070609 與我們聯系。

    猜你喜歡

    0條評論

    發表

    請遵守用戶 評論公約

    類似文章 更多
    喜歡該文的人也喜歡 更多

    2016年排五走势图